DotNetChecker plug-in

From NSIS Wiki

Author: ProjectHuman (talk, contrib)

README and source/binary


.NET Framework Checker NSIS plugin is used to detect if the required .NET Framwork is installed and if it is not - plugin will download and install the required package. Plugin C++ source code is based on the Aaron Stebner work described at

Works with 1.0/1.1/2.0/3.0/3.5/4.0 Full/4.0 Client, 4.5 and 4.5.1 Frameworks.

Unicode version

Added NSIS Unicode support and .NET Framework 4.5 support (for Unicode version only)

Get the Latest Version

Get the latest version with .Net 4.5 and 4.5.1 support from the project GitHub page.

Personal tools